Size calibration error - I'm baffled!

Anything goes! Cheap or expensive, FDM or SLA, DIY or Commercial.
Post Reply
DPhillips
Posts: 10
Joined: Tue Jan 16, 2018 1:24 am

Size calibration error - I'm baffled!

Post by DPhillips » Thu Nov 08, 2018 12:43 am

I'm not a newby, Been printing on my CR-10S for months now and I've produced many great items, both from web designs and from my own designs created in SolidWorks. Now here's my problem:
I am trying to make a simple box 161mm on a side. Using SolidWorks I lay out the box (I've been using SW for years, have no problem there).
Then I slice with Cura 3.4.1 as I've been doing. The printed box comes out about 7mm too small. So I went back to basics and printed the 20mm calibration cube </www.thingiverse.com/thing:214260> and it comes out exactly right. it seems the slicer and printer are OK. Next I laid out my own 20mm cube and it printed exactly right. So I try the box again, same problem, it is too small. So I went back to SW and using the same box I reduced it to a 161mm rod 3mm by 3mm. IT CAME OUT RIGHT, exactly 161mm.

So what is going on here? SW makes the right size test rod, made from the same box, but the box is undersize about 7mm.

Ideas are needed

gmedlicott
Posts: 3
Joined: Wed Nov 07, 2018 11:22 pm

Re: Size calibration error - I'm baffled!

Post by gmedlicott » Thu Nov 08, 2018 5:07 am

If it is a simple rectangular box, Cura will tell you the exterior dimensions of that box in the lower right of the printer window, prior to printing the part. If that dimension isn't what you're expecting, the problem likely lies upstream with the Solidworks file or STL export.

DPhillips
Posts: 10
Joined: Tue Jan 16, 2018 1:24 am

Re: Size calibration error - I'm baffled!

Post by DPhillips » Thu Nov 08, 2018 11:39 pm

Agreed. Cura says 161mm which is what I want. But it prints 7mm to small. Other things print at 100%, this one doesn't. Tried repeatedly.

Still baffled!

gmedlicott
Posts: 3
Joined: Wed Nov 07, 2018 11:22 pm

Re: Size calibration error - I'm baffled!

Post by gmedlicott » Fri Nov 09, 2018 12:43 am

Maybe try to rotate it 90' and print again. On my Folger FT5, the steps per unit was off in the firmware, causing an object to be correct in one orientation (say the x), but off in another (y). Or maybe a belt/stepper is slipping on or missing steps on one axis.

DPhillips
Posts: 10
Joined: Tue Jan 16, 2018 1:24 am

Re: Size calibration error - I'm baffled!

Post by DPhillips » Sun Nov 11, 2018 12:03 am

Those are the reasons I went back and printed the calibration cube, I came out exactly 20mm x 20mm x 20mm. Same for the similar cube I laid out in SolidWorks. It was fine too so I don't think there is any problem between the printer mechanism and the printer software and the slicer and SW. They all seem in sync until I print this particular Item.

Still baffled!

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests