Z crashing before print, not in auto home

Anything goes! Cheap or expensive, FDM or SLA, DIY or Commercial.
Post Reply
fiddleback33
Posts: 2
Joined: Wed Aug 08, 2018 5:53 pm

Z crashing before print, not in auto home

Post by fiddleback33 » Fri Aug 10, 2018 2:00 am

Hi, I've got an i3 clone, running Marlin 1.1.4. I'm trying to print from Cura's latest release, and after the auto home sequence(which works fine), it tries to send the nozzle down through the bed. Every time it happens, it pushes the z-endstop down, and has pushed out the z rod nut on the x carriage twice. Why might this be happening, especially after a successful auto-home? I haven't modified the g-code coming out of Cura, but here's the beginning sequence:

;FLAVOR:Marlin
;TIME:10622
;Filament used: 5.05928m
;Layer height: 0.15
;Generated with Cura_SteamEngine 3.4.1
M190 S60
M104 S190
M109 S190
M82 ;absolute extrusion mode
G28 ;Home
G1 Z0.0 F6000 ;Move the platform down 15mm
;Prime the extruder
G92 E0
G1 F200 E3
G92 E0
G92 E0
G1 F1500 E-6.5
;LAYER_COUNT:254
;LAYER:0
M107
G0 F3600 X71.33 Y84.239 Z0.3
;TYPE:SKIRT
G1 F1500 E0
G1 F1800 X71.706 Y83.932 E0.00913
G1 X73.032 Y82.915 E0.04057
G1 X73.682 Y82.467 E0.05541
G1 X74.374 Y82.086 E0.07027

Stefan
Posts: 223
Joined: Thu Jun 15, 2017 12:46 am

Re: Z crashing before print, not in auto home

Post by Stefan » Fri Aug 10, 2018 4:59 am

Hi fiddleback,

What is your z-offset? The line:

G1 Z0.0 F6000

Will definitely crash your extruder if the offset is incorrect. Auto home (G28) will set your Z to 0 at the point the endstop triggers minus z-offset. If your z-offset is too positive, your extruder will go right through the bed.

-Stefan

fiddleback33
Posts: 2
Joined: Wed Aug 08, 2018 5:53 pm

Re: Z crashing before print, not in auto home

Post by fiddleback33 » Fri Aug 10, 2018 5:34 am

That line was originally:
G1 Z15.0 F6000;

I tried to find my z-offset on the lcd, but that option seems to be locked out.
Where should I look for that in code? Configuration.h? I don't see the option in Repetier Host, so I'm at a loss.

Stefan
Posts: 223
Joined: Thu Jun 15, 2017 12:46 am

Re: Z crashing before print, not in auto home

Post by Stefan » Fri Aug 10, 2018 6:42 am

Hi fb,

Search in configuration.h for z-offset; it is definitely there.

-Stefan

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest