Runaway X axis on Tronxy X1

Where it began and what we all love most
Post Reply
rcbowman
Posts: 1
Joined: Thu May 31, 2018 5:49 am

Runaway X axis on Tronxy X1

Post by rcbowman » Thu May 31, 2018 6:45 am

Okay, so to get my feet wet in 3DP I bought a Tronxy X1. I had and solved a few problems with setup - I'm reasonably mechanically inclined and not afraid of electronics. I got it printing, and was looking forward to figuring out how to improve output when I had a little more time. Then it had two odd failures in a row. First, it started printing all the internal structure of a model (a fan shroud) without the actual walls. Made a lovely lattice, but not exactly what was needed. When I was trying to figure out what was happening, I lost track of the slippery bed leveling, and had the extruder collide with the bed as it went past the midpoint of the bed, and start pushing against it. I didn't notice and had it doing this for a few minutes before I stopped it. When I turned it back on, it had a new failure mode: as soon as the X axis was called upon to move in the positive direction, it instantly moved at high speed to the limit of the rail, and tried to keep going.

After retrying and having the same thing happen, I told it to print the original sample file that came with the printer, to eliminate variables. This time, it did its homing routine, then ran X out to the end, but at normal, slow speed. That only happened once. Since then it has gone back to doing that at full speed.

Home All and Home X work fine, but starting from Home, sometimes the X position reads as a gigantic number the instant it leaves the limit switch. And sometimes, if you use the X position fast control, it zooms all the way to max X, and tries to keep going, again until it is unplugged.

It seems like there is an issue with the board not recognizing the X position correctly, but I don't know enough about this to be sure of what errors I should be looking for. I checked the connectors on XPOS and XEND, and they seem fine. I don't know if this is a way stepper motors can fail, or if a connection is more likely the culprit, or one of the controllers on the board, or even the firmware. (The only reason I'm wondering about the firmware is that the previous problem, before this arose, was so bizarre: it apparently ignored all steps related to external walls of the part it was printing, and only printed the infill, resulting in a strange lacy lattice where the thin walls of the part should be.)

I had to set the printer aside for a while and deal with moving and some travel, but now I'd like to get back to this and start troubleshooting. Any suggestions where to start?

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest