TMC2130 non-working sensorless

Electronics, Components etc
Post Reply
mario.stoilov
Posts: 2
Joined: Tue Feb 06, 2018 5:59 pm

TMC2130 non-working sensorless

Post by mario.stoilov » Tue Feb 06, 2018 10:16 pm

Greetings guys,

I have a MKS gen 1.4, on which I am putting TMC2130 (from Watterott). I've wired them up as in Toms video and they seem to work - motors go in both directions, they are silent, no overheating and when calling M122 I see they have valid registers. The only thing, that is not working is the sensorless homing.

For some reason, when calling home on an axis, it immediately stops and gets its current position as home (if I disconnect the wire that goes to the S of the endstop, it crashes - no surprise ).

There is an example sketch from the tmc2130 library(Stallguard example), that is designed to be ran when the motors are free from the belts, giving you readings on how much your motor is struggling (values should change when you try to stall it by hand). I am getting no readings from there and I'm clueless on how to fix this issue.

Any suggestions?

Edi
Posts: 7
Joined: Wed Jan 24, 2018 11:57 am

Re: TMC2130 non-working sensorless

Post by Edi » Wed Feb 07, 2018 9:42 pm

Try changing the endstop pin inverted in configuration.h , worked for me for a bit but my x axis driver has gone haywire, I am troubleshooting as we speak, probably dodgy wiring.

Velomod
Posts: 3
Joined: Sun Feb 18, 2018 3:35 pm

Re: TMC2130 non-working sensorless

Post by Velomod » Sun Feb 18, 2018 3:55 pm

Try to increase the X_HOMING_SENSITIVITY and Y_HOMING_SENSITIVITY. You can use M914 to tune the values live. I had the same problem. That solved it for me.

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests