Dual Z issues

Have an issue you can't figure out on your own?
Post Reply
Meuljaym
Posts: 5
Joined: Mon Jul 02, 2018 9:30 pm

Dual Z issues

Post by Meuljaym » Thu Sep 20, 2018 3:43 am

anyone ever have an issue with their z motors turning at slightly different rates? my flsun i3 has dual z motors running off of one driver using one of those splitter boards and i can not get both motors to turn at the same rate. after doing one print the entire x axis is no longer level because of this. it appears to only be about 0.3 or 0.4 for every 100mm of height but its enough to throw everything off and require both a bed re-level and attempting to level out the x axis after almost every print.

Stefan
Posts: 223
Joined: Thu Jun 15, 2017 12:46 am

Re: Dual Z issues

Post by Stefan » Thu Sep 20, 2018 4:29 am

Hi Meuljaym,

Steppers are "digital". Either they are not tensioned evenly or one (or both) are not working properly. Unequal resistance can cause the motors to skip steps.

-Stefan

Meuljaym
Posts: 5
Joined: Mon Jul 02, 2018 9:30 pm

Re: Dual Z issues

Post by Meuljaym » Sun Sep 23, 2018 7:47 pm

I understand they are digital, and I don't believe it's a tension issue as they are both coupled to lead screws. I do use lithium grease on the lead screws to help with friction. Both sides of the x axis are supported by wheels with no way of adjusting the tension, but do move freely.

Stefan
Posts: 223
Joined: Thu Jun 15, 2017 12:46 am

Re: Dual Z issues

Post by Stefan » Sun Sep 23, 2018 11:18 pm

Hi Meuljaym,

Is the x-axis trammed?

-Stefan

Meuljaym
Posts: 5
Joined: Mon Jul 02, 2018 9:30 pm

Re: Dual Z issues

Post by Meuljaym » Mon Sep 24, 2018 2:02 am

It begins trammed but due to different rotation of motors one side either looses or gains approx. 0.3-0.4mm for every 100mm of z travel.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest