Need desperate help with tmc2130 :(

Have an issue you can't figure out on your own?
anthonyyaghi
Posts: 9
Joined: Sun Oct 14, 2018 8:09 am

Re: Need desperate help with tmc2130 :(

Post by anthonyyaghi » Sat Oct 20, 2018 6:09 pm

Ok so finally I got a new RAMPS board with an arduino mega instead of the MKS board and everything is working fine. Thanks a lot Stefan :)

Btw I am facing a new problem the filament keeps on breaking inside the nozzle, but the filament I have has been sitting in not so optimal storing conditions for like 4-5 months. I guess that is the problem and I ordered new filaments. But I want to ask you guys since you know better could this be a problem with the nozzle not heating up well or is it the filament for sure ?

Thank you
Anthony

Stefan
Posts: 223
Joined: Thu Jun 15, 2017 12:46 am

Re: Need desperate help with tmc2130 :(

Post by Stefan » Sat Oct 20, 2018 10:10 pm

Glad to hear it is running, Anthony. Breaking PLA usually means age/exposure. You are already doing the best test by replacing it, so you will know soon.

-Stefan

anthonyyaghi
Posts: 9
Joined: Sun Oct 14, 2018 8:09 am

Re: Need desperate help with tmc2130 :(

Post by anthonyyaghi » Sun Oct 21, 2018 10:04 am

Thank you, filament is ok now but another problem appear :roll: I doubled the step/mm settings since the DRV8825 have 32 microstep double the 16 of the A4988. But the problem now is that the stepper motor of the extruder doesn't work with the new setting it just make buzzing sounds but doesn't turn. If I revert back to the old settings (400 steps/mm new is 800) it works fine but it is too fast... Any ideas ?

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest