Marlin with: MKS GEN 1.4 + TMC2130

3D Modelling, Slicing, Hosts and Management
mesnik
Posts: 42
Joined: Sat Dec 30, 2017 7:53 pm

Re: Marlin with: MKS GEN 1.4 + TMC2130

Post by mesnik » Fri Jan 05, 2018 3:42 am

Thanks for the info!

The only thing I had different was the motherboard. I had 33 and also tried 47... I have now switched to match yours.

But still no go. The blue screen of death!!!

mesnik
Posts: 42
Joined: Sat Dec 30, 2017 7:53 pm

Re: Marlin with: MKS GEN 1.4 + TMC2130

Post by mesnik » Fri Jan 05, 2018 3:45 am

How about language and charset, do we leave that uncommented?

And are you running the TMC2130s?

Oh, one more thing, on the endstop connectors, from the Anet board, the connector is also a three-pin one, but the plus is on the far left and the minus on the far right... looks like that needs to be modified to match the mks gen, right? Do you have red on the far right, and black in the middle?
Thanks again!

chumm
Posts: 176
Joined: Thu Jun 15, 2017 11:24 am

Re: Marlin with: MKS GEN 1.4 + TMC2130

Post by chumm » Fri Jan 05, 2018 4:10 am

Yeah red, black, green (signal) left to right on MKS-Gen.

Charset shouldn't matter on a graphical display, language I have set to en, not commented out:

Code: Select all

/**
 * LCD LANGUAGE
 *
 * Select the language to display on the LCD. These languages are available:
 *
 *    en, an, bg, ca, cn, cz, cz_utf8, de, el, el-gr, es, eu, fi, fr, gl, hr,
 *    it, kana, kana_utf8, nl, pl, pt, pt_utf8, pt-br, pt-br_utf8, ru, sk_utf8,
 *    tr, uk, zh_CN, zh_TW, test
 *
 * :{ 'en':'English', 'an':'Aragonese', 'bg':'Bulgarian', 'ca':'Catalan', 'cn':'Chinese', 'cz':'Czech', 'cz_utf8':'Czech (UTF8)', 'de':'German', 'el':'Greek', 'el-gr':'Greek (Greece)', 'es':'Spanish', 'eu':'Basque-Euskera', 'fi':'Finnish', 'fr':'French', 'gl':'Galician', 'hr':'Croatian', 'it':'Italian', 'kana':'Japanese', 'kana_utf8':'Japanese (UTF8)', 'nl':'Dutch', 'pl':'Polish', 'pt':'Portuguese', 'pt-br':'Portuguese (Brazilian)', 'pt-br_utf8':'Portuguese (Brazilian UTF8)', 'pt_utf8':'Portuguese (UTF8)', 'ru':'Russian', 'sk_utf8':'Slovak (UTF8)', 'tr':'Turkish', 'uk':'Ukrainian', 'zh_CN':'Chinese (Simplified)', 'zh_TW':'Chinese (Taiwan)', test':'TEST' }
 */
#define LCD_LANGUAGE en
I don't have the 2130s so can't help there.

mesnik
Posts: 42
Joined: Sat Dec 30, 2017 7:53 pm

Re: Marlin with: MKS GEN 1.4 + TMC2130

Post by mesnik » Fri Jan 05, 2018 4:27 am

I have a feeling the tmcs are messing up the lcd...

I will change my limit switch... thanks for that!!

mesnik
Posts: 42
Joined: Sat Dec 30, 2017 7:53 pm

Re: Marlin with: MKS GEN 1.4 + TMC2130

Post by mesnik » Sun Jan 07, 2018 12:36 am

Here is an issue that I posted at Git, as I think it may be a configuration in Marlin?


Description: Printer halts before finishing firs layer (benchy boat). Have to reboot printer, but issue persists.

Expected behaviour: Print the entire part without stopping mid print.

Actual behaviour: in the middle of the firslt layer, the printer halts requiring reboot.

Steps to reproduce: every time I send a part to print, using Simplify3D.

Got this error message once:
READ: E driver error detected:
READ: Error:Printer halted. kill() called!
WARNING: Firmware unresponsive. Attempting to force continue...


And this on the next repeating attempts:
READ: E driver error detected:
READ: overtemperature
READ: Error:Printer halted. kill() called!
WARNING: Firmware unresponsive. Attempting to force continue...


EXTRA INFO: I first had a bad TMC driver (noticed a small splatter of solder on the pot) and I replaced it on the X axis. I have since swapped the X TMC with the extruder TMC in case that driver was also damaged BUT issue still happening the same way. So in my mind, I am either connecting the extruder TMC to wrong pins (I am following Tom's youtube layout - have checked at least 10 times with at least 4 different cables) or I have something missing/wrong on the firmware.

I can also add that is not the power supply as I hooked up a 45A, heavy duty to it and it did the same thing...
; )

Thanks for the time!!

slippyr4
Posts: 224
Joined: Thu Jun 15, 2017 10:24 am

Re: Marlin with: MKS GEN 1.4 + TMC2130

Post by slippyr4 » Sun Jan 07, 2018 8:43 am

Could it be that your driver is overheating? After all, that’s what the error message says!!
Self-built Prusa i3 MK2 clone
My things: https://www.thingiverse.com/slippyr4/designs
My Prusa firmware port for ramps & MKS : https://github.com/slippyr4/Prusa-Firmware

mesnik
Posts: 42
Joined: Sat Dec 30, 2017 7:53 pm

Re: Marlin with: MKS GEN 1.4 + TMC2130

Post by mesnik » Sun Jan 07, 2018 3:31 pm

I don’t have any heat sinks or fans on them... do they need heat sinks? If so, that could be a possibility! Let me blow a fan on them and check.

Thanks!!

oakdesign
Posts: 109
Joined: Thu Jun 15, 2017 10:21 am

Re: Marlin with: MKS GEN 1.4 + TMC2130

Post by oakdesign » Sun Jan 07, 2018 5:01 pm

to operate 2130 I recommend to use in any case both heatsinks and active cooling
Opa's bester Rat: Probieren geht über Studieren, Grandpas best advice: the proof of the pudding is in the eating

mesnik
Posts: 42
Joined: Sat Dec 30, 2017 7:53 pm

Re: Marlin with: MKS GEN 1.4 + TMC2130

Post by mesnik » Sun Jan 07, 2018 6:10 pm

GENIUS!! It worked!!!

A huge fan let the printer go to the end!!! Yesssssss, holy crap that was annoying!

On to buy some heatsinks and wire in a case fan..

I cannot thank you enough, man!!! Thank you so much!!

Take care!

oakdesign
Posts: 109
Joined: Thu Jun 15, 2017 10:21 am

Re: Marlin with: MKS GEN 1.4 + TMC2130

Post by oakdesign » Mon Jan 08, 2018 1:16 am

Marlin has a contrióller board feature . If have mine hooked up with a IRF520 and one signal wire from the D5 pin. So the Board fan turns on a soon as one of the stepper gets active and turns off 1min after the last stepper is inactive. Basically the same way Thomas shows in his video on wiring up LED just a Fan instead of an LED and controlling not theough M42 GCode (wich works in addition to the Marlin integrated function)
Opa's bester Rat: Probieren geht über Studieren, Grandpas best advice: the proof of the pudding is in the eating

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests