Page 1 of 1

Auto home does not take hotbed back

Posted: Fri May 11, 2018 12:55 pm
by kraut55
Hi,
I am a newbie to 3d-printing. I built a Prusa Mk2 clone (made by CTC) and am slowly trying to get the hang of it.
A few days ago a small problem started. Whenever I do an "Auto home" only the extruder assembly returns to the origin. The hotbed stays where it is and I have to manually push it back.

Re: Auto home does not take hotbed back

Posted: Fri May 11, 2018 9:28 pm
by Stefan
Hi kraut55,

Welcome to the forum. Post your config.h. Does the y-axis move with commands or during printing?

-S

Re: Auto home does not take hotbed back

Posted: Sat May 12, 2018 12:21 pm
by kraut55
Hi Stefan,
thank you for the welcome and your fast replay.
Config do you mean the slicer's config? If so, there are so many parameters. Which ones would you need?
As mentioned I am a beginner so there is no g-code that I would send directly to the printer. I usually grab an stl-file, have the slicer do its work, save it to the SD card and insert the card into the printer.
During printing the y-axis moves just fine.
Tks.

Re: Auto home does not take hotbed back

Posted: Sun May 13, 2018 3:40 am
by Stefan
Hi kraut55,

I'm referring to a file in your firmware (I'm assuming you are using Marlin). The config.h tells the printer all of the physical parameters of your machine, including how long your y-axis is, where it starts, and where it ends. I have a suspicion they may not be properly configured.

-S

Re: Auto home does not take hotbed back

Posted: Wed May 16, 2018 5:58 pm
by kraut55
Will try to find out how I can access the firmware and will let you know.

Re: Auto home does not take hotbed back

Posted: Wed May 23, 2018 12:33 pm
by kraut55
The LCD does not show any information which firmware/version it uses and the included manual advises not to upgrade the firmware. The board is a 2560 Rev A. Can that be used with different kinds of firmware or is there a dedicated firmware? Sorry but you can see I am completely new to 3d printing.

The problem itself has been solved! For some reason the g-code did not include a "home for all axis". I added a G28 and the hotbed moved on the Y-axis. Wrong direction but I guess I can find out why.

I would appreciate if you could give me some info about the board/firmware in case I should need an update or I would have to apply changes when I try to connect the printer to my Mac.
Thank you.

Re: Auto home does not take hotbed back

Posted: Wed May 23, 2018 7:29 pm
by Stefan
Hi kraut55,

You can flip the wiring on the y-axis motor to make it go the right way. There is a USB port on your arduino that allows you to transfer firmware. Visit https://www.arduino.cc/en/Main/Software to find the right version for you. I'm not sure how to read what is already on your board, so unless you can get a copy of the firmware from the original builder, you may need to start with a new version of Marlin. Reversing the direction of your y-axis motor can be done through firmware, too.

Tom has a good video about uploading firmware to an arduino, so I'd check that out.

Keep in mind that G28 not only homes but will also clear autoleveling information stored in RAM. I usually G28 (all home) G29 (get autoleveling data) then M420 S1 (turn on autoleveling). If I G28 again, I have to do the others again. (Note, I G29 after I heat the bed so I get the most accurate readings I can - the bed warps a bit when it gets hot).

-Stefan