Firmware Problems.

Have an issue you can't figure out on your own?
Post Reply
Posts: 2
Joined: Tue Jul 04, 2017 6:24 pm

Firmware Problems.

Post by Dragnaros » Tue Jul 04, 2017 6:42 pm


i have a Turnigy Fabrikator from Hobby King. The old big one not the new mini.

i wanted to upgrade my nozzle to a E3DV6 (on the original i was not able to change the nozzle)

i did change the hotend and adjustet the z endstop and wanted to print then i did realize that the thermistor did not work.

Problem: wrong firmware settings. ok change it...

Problem: No support for this printer and no firmware download. i found a link on youtupe where a kind person did upload the original firmware

so i tried to upload the firmware. no sucsess because of compiling errors.

so i tried to modify and upload the new Marlin firmware. Sucsess

Problem: seems to ignore my endstops (Magnetic endstops). later i did realize that it enters the endstop and ceeps moving but does not go back seems invertet but i can not get to the wires without rebuilding the entire printer.

so i did try the original firmware again and it worked with a older version of arduino software. seems to work fine but as i wanted to load the filament... the Extruder motor does not respond.

i did not touch the motor wires so i think it is a firmware problem.

could someone try to adjust the new marlin firmware to the printer with the original marlin firmware as a base?
i keep trying and everything gets worse.

Posts: 41
Joined: Thu Jun 15, 2017 4:00 am
Location: Holland

Re: Firmware Problems.

Post by ronka » Wed Jul 05, 2017 8:03 pm

is this helpfull?

can you tell the world what kind of board is beeing used in this printer?? (marlin has lots of boards preset but you can alter things to suit your board.)

Posts: 2
Joined: Tue Jul 04, 2017 6:24 pm

Re: Firmware Problems.

Post by Dragnaros » Thu Jul 06, 2017 6:54 pm

should be the "RAMPS 1.3 / 1.4" Board
i will try the file tomorrow.

Thank you verry much for your answer.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests