Page 1 of 1

Tevo Little Monster Help Needed

Posted: Fri Nov 24, 2017 5:58 pm
by domino6713
After watching several videos on the TLM (Tom's included), I decided to purchase the kit as my first 3D printer. Putting it together went fairly smoothly. I too had one un-tapped part, though not the same part. Easy fix. When I powered it on, the lights for the end stops all lit up. They also turn off when I manually push the carriage to the top. The BL Touch is glowing a steady red. It responds to the up/down/test commands from the input screen. With all of those things working, I touched the calibrate icon. The head immediately crashed into the center of the glass and then moved to the back of the bed and proceeded to grind there. I rebooted the machine and tried again. Same result. The machine also will not home on it's own. In fact, I can't get the touchscreen to cause any movement at all unless I press calibrate.

I went online and found a link to a firmware upgrade for the machine. Followed the instructions to load the required files onto the microSD and the SD card. As soon as I turned the machine on this time, it lowered to the bed, crashed into the center, and then moved to the back to grind there. It was doing this while the firmware update was occurring. I didn't want to turn it off during the update so I left it alone. It finished the update and actually stopped grinding, but still wouldn't move. I rebooted. Just as soon as I turned it back on, the head crashed into the bed again and move to the back. I put the original files back on the cards which put me back at square one.

In summary
--the device will not home
--trying to calibrate results in the head crashing into the middle of the bed and then moving to the back to grind there for several seconds
--the BL touch and end stops seem to be working
--I don't know if the heat bed is working because it hasn't been on long enough to know. The bed temperature is being reported as -50/50. I'm not sure what that means, but it isn't something I would expect to see. The hot end is reporting a temperature of 5.
--flashing to firmware I found online in a Tevo forum made the issue worse.

OH, I do have one other thing of note...the belts all have a twist in them. Is that normal? In order to undo it, I would have to cut one side of them and re-attach it. Since they are all like that, I thought it was normal although I also think that might be why it is crashing into the bed rather than homing. A twisted belt would make it move in the opposite direction. It doesn't explain why it won't move when I press any of the movement buttons though. If my hypothesis is correct, pressing home should also result in the head moving to the bed.

Is there anything anyone can suggest that might solve my issues?

Re: Tevo Little Monster Help Needed

Posted: Sat Nov 25, 2017 5:59 pm
by PartTimeRonin
A detail pic of the belt you're talking about would be nice.
And where did you get the new firmware from?
Also did you check if the endstop on each tower is working?

Re: Tevo Little Monster Help Needed

Posted: Sun Nov 26, 2017 6:47 pm
by domino6713
Thanks for responding. The belts were twisted like an infinity symbol. I took everything apart and put it back together correctly. I had tested the end stops, and they are working. After fixing the belts, the carriage moved correctly. The problem with the heater bed temperature was actually two problems. The ground wire in one of the plugs wasn't connected. I fixed that. It still wasn't reading correctly. After looking at the board diagram in the manual and noticed that the plug was in the wrong spot. After moving it to the correct place, everything started working. I've made several calibration tests. Things seem to be going well so far.