Page 2 of 2

Re: Problem compiling Marlin

Posted: Fri Nov 10, 2017 12:59 pm
by aliasmeum
Hello,

For anyone else struggling with this, here is an update on what I did to solve the problem.

I ended up using the official Marlin 1.1.6 release and do the necessary changes for my Taz5 in "Configuration.h" and "Configuration_adv.h", using the configuration files from Lulzbots "Marlin_TAZ45_Uaru_1.0.0.1" and Lulzbots Marlin-1.1.5 for TAZ6 as reference.
This is now working perfectly for me, but my Taz5 is modified, and my configurations would not work for a stock Taz5.

Today I have edited the configuration files so that they should be right for a stock Taz5. Please consider that this configuration has not been tested, but the files are attached. I have also attached a file that shows all the changes that I have done, compared to the official Marlin release. IMPORTANT: Also note that this configuration is for normally closed (NC) end-stop switches. I chose to keep this configuration since this is considered a safer solution. You can either change this in "Configuration.h" or you can connect your end-stops as NC-switches. You do this simply by moving the middle connector to the free pin on the end-stop switch.

If you want to go on using my files, at your own risk, I will recommend this procedure:
- Download latest Marlin release, currently 1.1.6, from Marlins official site (http://marlinfw.org/meta/download/)
- Copy and paste the content of my attached file "Configuration.h(Taz5).odt" to a text file and replace this file with the "Configuration.h" file in the Marlin folder.
- Copy and paste the content of my attached file "Configuration_adv.h(Taz5).odt" to a text file and replace this file with the "Configuration_adv.h" file in the Marlin folder.
- Download Arduino IDE 1.8.5 from (https://www.arduino.cc/en/Main/Software)
- In Arduino IDE, install the U8glib library. From the menu "Sketch/Include Library/Manage Libraries". Search for U8glib, choose version 1.19.1 and Install it.
- Connect to your printers USB port and upload the new firmware.

I hope this is a solution that can help you.
Best regards
Robert