TMC2130 V1.0 Question

Electronics, Components etc
oakdesign
Posts: 109
Joined: Thu Jun 15, 2017 10:21 am

Re: TMC2130 V1.0 Question

Post by oakdesign » Fri Jul 06, 2018 3:26 pm

Apparently as your Driver is fine I would look into Software Settings.
A) Is the current maybe already set for 2 Steppers in parallel. This might cause overheating in seconds.
Next from a former discussion
I changed DEFAULT_MAX_FEEDRATE to 3 for the Z axis in Configuration.h and it seem to work!
Regards
Opa's bester Rat: Probieren geht über Studieren, Grandpas best advice: the proof of the pudding is in the eating

unixb0y
Posts: 30
Joined: Wed Apr 18, 2018 4:45 pm

Re: TMC2130 V1.0 Question

Post by unixb0y » Fri Jul 06, 2018 7:02 pm

How do I know whether they're setup for parallel or series and how can I change it?
That value is 5 in my case, so I don't know if setting it to 3 makes a big difference.
Thank you for the 1st tip though!
~ Dave ~

oakdesign
Posts: 109
Joined: Thu Jun 15, 2017 10:21 am

Re: TMC2130 V1.0 Question

Post by oakdesign » Fri Jul 06, 2018 7:57 pm

Usually you set the Z driver to a higher current as you are driving 2 Motors from one driver. So if you connect only a single Motor for testing check current on the driver.
Opa's bester Rat: Probieren geht über Studieren, Grandpas best advice: the proof of the pudding is in the eating

unixb0y
Posts: 30
Joined: Wed Apr 18, 2018 4:45 pm

Re: TMC2130 V1.0 Question

Post by unixb0y » Fri Jul 06, 2018 8:17 pm

This is the result of M122:
X, Y, Z and M0 are equipped and setup for TMC2130.
Apparently, the current is set to 0?

Image

In the firmware configuration I've set them all to 800mA.

EDIT:
I don't know if setting the current via M906 did anything (at least now it shows it when calling M122) but the trick really was to limit the max feedrate.
3 seems quite okay, as well so thanks again and have a nice day! ;-)
~ Dave ~

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests