Page 1 of 4

Yet another TMC2130 problem

Posted: Tue Jun 12, 2018 11:05 pm
by christopher.theobald
Hi All,

Apologies for this, I have had a look through and can see that there are a lot of posts about 2130s, but none of the ones I have seen seem to have the same error as the one I am getting now.

Basically, I am using a Ramps board on what was, once a long time ago, and anet a8. I have put 2130s on the X, Y and Z axis. (A relilable 2100 on the extruder).

I get a rather generic error when connecting to the printer using pronterface.

I have changed the wiring, moved the drivers changed the pins.

I have followed Tom's video as well as this instructable - ... r-Drivers/

I have tried multiple times.

As far as i can tell the drivers are configured for SPI. I ordered them from Watterott.

The error i received is below +other info posted.

Any advice?

Y driver error detected:
Enabled false false false
Set current 500 500 500
RMS current 489 489 883
MAX current 689 689 1245
Run current 15/31 15/31 15/31
Hold current 12/31 12/31 12/31
CS actual 12/31 12/31 0/31
PWM scale 0 1 0
vsense 1=.18 1=.18 0=.325
stealthChop true true false
msteps 16 16 256
tstep 1048575 1048575 0
threshold 98 98 658
[mm/s] 80.68 80.68 48.06
OT prewarn false false false
OT prewarn has
been triggered false false false
off time 5 5 0
blank time 24 24 16
-end 2 2 -3
-start 3 3 1
Stallguard thrs 8 8 0
sg_result 0 0 0
stst X X
Driver registers:
X = 0x80:0C:00:00
Y = 0x80:0C:00:00
Z = 0x00:00:00:00
Error:Printer halted. kill() called!
[ERROR] Error:Printer halted. kill() called!

Re: Yet another TMC2130 problem

Posted: Wed Jun 13, 2018 12:30 am
by Stefan
Hi Chris,

First thing that stands out is something on the Z driver (not the Y). You're RMS current is running above your set current. Try "M906 X500 Y500 Z500" to set the mA for all three drivers. THEN, reset the EEPROM with "M500". For some reason, Marlin has difficulty setting those values after flashing the firmware.

Have you tried isolating the problem by returning the old driver back to the Y-axis (and reconfiguring Marlin again)?


Re: Yet another TMC2130 problem

Posted: Wed Jun 13, 2018 12:58 pm
by christopher.theobald
Hi Stefan,

I hadn't noticed that, good spot. Normally i try to set the value in marlin just in case things get forgotten. When i get back i will reset the values as you describe as, if nothing else, this will stop the next error its likely to show me!

I haven't replaced the 2130 entirely, i did have a set of 2100s working without much of an issue before hand. I could put that back in, but as i had switched the Y and Z 2130, and the error stayed with the Y, I assumed this wouldn't do much but push the error elsewhere. Again, i can try this later for confirmation, but i guess i would expect it to start complaining about the X or Z.

Are you, or can anyone else, confirm if the drivers come from Watterott set in SPI mode by default? I haven't made any changes to them in this regard as they looked correct, but i am wondering if i was being a bit blind.

Kind regards,

Re: Yet another TMC2130 problem

Posted: Wed Jun 13, 2018 5:06 pm
by Stefan
Hi Chris,

I bought mine from Filastuder (American affiliate) so I couldn't say for sure which configuration Watterott carries. I'd still go back to trying to run just the X or Z on its own. It's a pain, but I think it would eliminate a bunch of cases.


Re: Yet another TMC2130 problem

Posted: Thu Jun 14, 2018 12:36 am
by christopher.theobald
in true organised fashion, i cant for the life of me find my old drivers. I doubt i'd have been stupid enough to throw them out, knowing i have had trouble with the 2130s int he past. but regardless, i can't find them yet. I will take a look again and see what I find.

What i tried however, was to disable to disable the #define MONITOR_DRIVER_STATUS

what i found was that the X axis worked flawlessly, aside from the sensor-less end-stopping being a touch too sensitive.

The why axis buzzed but over all didnt move

The z axis didnt even try to move.

All drivers got hot, specifically Y and Z.

They were all set to 800ma according to the returned message when starting up. Oncreasing the y to 850, unsurprisingly chanhed nothing.

I needed some active cooling on the 2100s so assumed i might on these, but as they weren't doing anything i didn't expect that much heat.

I think that as the X works, its safe to assume that theu are shipped in SPI mode.

My plan for tomorrow is to recheck the wiring on Z and track down my 2100s, where-ever they may be and report back.

Re: Yet another TMC2130 problem

Posted: Thu Jun 14, 2018 3:04 am
by Stefan
Hi Chris,

Sounds like progress. Dumb question, are you using an up to date Marlin? Everything you are now describing sounds like current issues. I run my drivers at 650mA with passive cooling and just barely get by. 800mA caused immediate shutdown.


Re: Yet another TMC2130 problem

Posted: Thu Jun 14, 2018 11:21 am
by christopher.theobald
I am using marlin 1.1.8

Would it be better to go back to 1.1.6 as in Tom's video?

I will lower to the 600 mark and see if this does help, it may be thermal shut down.

Re: Yet another TMC2130 problem

Posted: Thu Jun 14, 2018 1:57 pm
by Moorviper
which voltage has your printer?
12V or 24V?

the tmc2130 doesn't work well with 12V

Re: Yet another TMC2130 problem

Posted: Thu Jun 14, 2018 2:22 pm
by christopher.theobald
It is 12v. Not saying I disagree as I will admit I don't know enough about them but I have seen a lot of people using them on 12v systems.

Re: Yet another TMC2130 problem

Posted: Thu Jun 14, 2018 5:18 pm
by Moorviper
3 good videos by Alex Kenis tmc2130 (one of them stepper driver in general related).

5mdd - TMC2130 & RAMPS with LCD and SD reader:

TMC2130 WHINE: advanced troubleshooting for stubborn steppers:

Ramps 5 of 5 - stepper drivers:

should give you some answers.
Alex says that the Trinamic normally should run with 28V and 24V is already low.
I had no good experience with 12v.