Page 1 of 1

I think i broke it (RAMPS 1.5 board with Arduino Mega)

Posted: Thu Jun 21, 2018 3:23 pm
by christopher.theobald
Hi all,

Having an issue that google isnt really helping me with (more accurately i'm probably not searching for the correct terms...) so im looking for some advice.

Literally the power cycle after getting my tmc2130s to work (finally!) i turn on my printer to begin calibrating etc and, nothing. It's dead Jim. No power.

I had been using an old PSU, and i had overjuiced it to increase heat up times, so figured maybe i'd killed that. So i bought another one. Same thing.

I got a multimeter and both PSUs seems to be putting out voltage.

I used my new fangled tool to check the plug on the ramps board, and that seemed to be getting juice.

however, no response when connecting it to my laptop, no movement and no fans etc.

I hadn't moved anything relating to the PSU or the power plug at all during the TMC2130 install process. So, as it had been working fine for months before that, i dont think it would be reversed polarity.

Is anyone able to recommend what to check to see if it's a dead ramps or a dead arduino, or both?

Thanks,
Chris

Re: I think i broke it (RAMPS 1.5 board with Arduino Mega)

Posted: Fri Jun 22, 2018 5:35 am
by Stefan
Hi Chris,

If you plug your laptop into the arduino, you should get the LCD to light-up (the USB has nowhere's enough power to run the motors). If this fails, my first guess would be the arduino. I've blown up a few. Also, if you are using a "1.5" does it have poly fuses or those little one-use surface mount fuses?

-Stefan

Re: I think i broke it (RAMPS 1.5 board with Arduino Mega)

Posted: Sat Jun 23, 2018 2:28 am
by christopher.theobald
No poly fuses, so i assume surface mounted.

I tried the same set up, just swapped out for a MKS Gen L, and this all worked (to a point).

I'm not a huge fan of the RAMPS anyway, so i might just take this as an excuse to get an all in one board.

I think i broke it RAMPS 1 5 board with Arduino Mega

Posted: Wed Aug 08, 2018 4:29 pm
by KomenasJuh
I just bought a EVB and I like to connect with on an Arduino TX, RX , how you doing?
Best regards